Για άλλη μια φορά φέτος (όπως και πρόπερσι) το greasemonkey δίνει λύση για τη συμπλήρωση ερωτηματολογίων των μαθητών. Παραθέτω τον κώδικα:

function fillnsubmit() {
  document.getElementById('txtUsername-inputEl').value = "username_goes_here";
  document.getElementById('txtPassword-inputEl').value = "password_goes_here";
  document.getElementById('btnLogin-btnEl').click();
  
}

document.addEventListener('DOMContentLoaded', function() {
    setTimeout(fillnsubmit, 2000);
})

Only with IE6!!Έγραφα πριν λίγες μέρες για το μικρό προγραμματάκι που έφτιαξα για να κάνει την δουλειά μου ευκολότερη (άθροιση στοιχείων από πολλά αρχεία excel). Αυτό το κομμάτι τελείωσε με επιτυχία (μετά και από την απαραίτητη βοήθεια στο sql κομμάτι 😉 ). Το επόμενο στάδιο ήτανε να καταχωρίσω τα συγκεντρωτικά στοιχεία στο ηλεκτρονικό σύστημα παραγγελιών βιβλίων του ΟΕΔΒ. Δοκιμάζω λοιπόν να μπω με τον Firefox και εισπράττω το παρακάτω μήνυμα :

“…Για τη σωστή λειτουργία του ιστοτόπου θα πρέπει ο φυλλομετρητής που χρησιμοποιείτε να είναι Microsoft Internet Explorer (ver. 6+) …”.

Για να χρησιμοποιήσει λοιπόν κάποιος το σύστημα του Οργανισμoύ Εκδόσεων Διδακτικών Βιβλίων θα πρέπει να έχει υποχρεωτικά MS IE6+ (αν πατήσεις OK στο παραπάνω παράθυρο σε κάνει redirect στην κεντρική σελίδα του ΟΕΔΒ!!!). Εντάξει στην τελική δεν είναι πρόβλημα να μπεις με τον firefox, υπάρχουν διάφοροι τρόποι να το κάνεις (π.χ. απενεργοποίηση javascript με το noscript ή αλλαγή user agent με το καταπληκτικό extension user agent switcher και το απαιραίτητο του συμπλήρωμα για extra agents) ή ακόμη να μπεις κανονικά με ΙΕ6 από linux με το ies4linux, αλλά το θέμα είναι γιατί; Γιατί ΙΕ 6 ενώ ξέρετε (ή θα έπρεπε να ξέρετε) ότι είναι από πλευράς τήρησης των Web Standards είναι ο χειρότερος browser που υπάρχει. Γιατί είναι (ακόμη) ο πιο δημοφιλής; Διάβαζα πριν λίγο καιρό (εδώ) ότι ένας από τους λόγους που δεν θα προσλάμβανες κάποιον για να σου φτιάξει ένα site είναι να έβλεπες στις άλλες δουλειές του ότι βάζει την επιγραφή “…Best if viewed in…”. Θα ήθελα να δώ το μικρό σκριπτάκι από το savethedevelopers.org που ανιχνεύει τον IE6 και βγάζει ένα μικρό παραθυράκι που προτείνει αλλαγή browser (firefox, opera, flock, safari) ή έστω αναβάθμιση σε IE7 που είναι μια πολύ καλή πρωτοβουλία, όπως έγραψε ο nikan στο metablogging.gr

Η HTML αποτελεί την βάση των περισσότερων ιστοσελίδων αλλά είναι προβληματική… Το γεγονός ότι δεν είναι αυστηρά δομημένη δημιουργεί πολλά προβλήματα, ιδιαίτερα στο τομέα απεικόνισης της στους διάφορους browsers. Για αυτό λοιπόν το W3C πρότεινε την XHTML – μια αυστηρή HTML με αλλά λόγια. Στην XHTML λοιπόν δεν επιτρέπονται tags τα οποία ανοίγουνε και δεν κλείνουνε, ή tags που δεν είναι σωστά ενθυλακωμένα, μεταξύ άλλων. Οι περισσότερες open source web εφαρμογές ακολουθούν αυστηρά τις προδιαγραφές της XHTML (π.χ. wordpress) αλλά όχι και τα μεγάλα εμπορικά site. Continue reading “XHTML valid…”

Δεν ξέρω αν συμβαίνει μόνο σε μένα αλλά εδώ και λίγες μέρες ο firefox “κρεμάει” συνεχώς. Ειδικά στο Gmail το οποίο έχω καταντήσει να φοβάμαι να ανοίξω… Δεν γίνεται όμως να μην βλέπω τα e-mail μου. Τα κολλήματα δεν αφορούν μόνο το Ubuntu αλλά και τα Windows. Μετά ειδικά και απο τις διαδοχικές εκδόσεις 2.0.0.10 και 2.0.0.11 μέσα σε λίγες μόνο μέρες, μάλλον κάτι δεν πάει καλά γενικότερα. Δυστυχώς στο Ubuntu (64bit έκδοση) ακόμα περιμένω να με ειδοποιήσει ο update manager για την καινούργια έκδοση (2.0.0.11). Φαντάζομαι όμως οτι το update είναι θέμα ωρών.

Άσχετο αλλά βγήκε και καινούργια έκδοση flash player 9 (με ειδοποίησε ένα application του facebook!!) με υποστήριξη για Linux (thumbs up for Adobe) αλλά μόνο για x86 (thumbs down for Adobe). Αν έχεις επεξεργαστή και 64bit έκδοση (όπως εγώ) τότε πρέπει να κάνει μερικές αλχημείες για να βλέπεις flash. (Μιας και περί flash ο λόγος, να ένα χαζό παιχνιδάκι για ώρες μεγάλης (μα πολύ μεγάλης) βαρεμάρας).

Update 2007/5/12: Ο firefox 2.0.0.11 είναι διαθέσιμος στα repositories του Ubuntu από σήμερα. Ελπίζω να λύσει τα προβλήματα.